
File Menu

New...
Opens a New Document Window.

Related Topic:
Opening New Document Windows

Open... 
Opens an existing graphic in a new document window.

Related Topic:
Opening Existing Graphic Files

Save 
Saves changes to the graphic in the current window.

Related Topic:
Saving Changes to Existing Files

Save As... 
Saves the graphic in the current window to a file of your choice.
Related Topic:
Saving New Images
Open, Apply, Save...
Opens an existing graphic file, applies the selected changes to the file attributes, and saves the file with 
the change.

Related Topic:
Automatically Saving Changes to Multiple Files
Delete
Deletes the current window.

Related Topic:
Deleting Graphic Files
Printer Setup...
Selects a printer driver and a printer connection.

Print
Prints the image in the active document window.

Related Topic:
Printing Graphic Files
Page Setup...
Sets the top, bottom, left, and right margins and specifies information to be included in the header and 
footer of a printed page.

Related Topic:



Changing the Page Setup
Exit
Exits RezSolution.    Lets you save unsaved changes before quitting.

Related Topic:
Quitting RezSolution



Edit Menu

Undo
The image in the current window is restored to its previous status.

Related Topic:
Undoing Applied Changes
Copy 
Copies a selected area to the current document window.

Related Topic:
Copying an Image to the Clipboard Viewer
Paste 
Pastes the contents of the clipboard into the current document window.

Related Topic:
Pasting an Image from the Clipboard
Clear 
Clears the current document window (or the Clipboard Viewer).

Select All
Selects the entire graphic image in the current document window.

Copy To... 
Copies the selected area to a file.



Capture Menu

Capture Region
Activates the region capture function.

Related Topic:
Capturing a Region
Capture Window
Activates the capture window function.

Related Topic:
Capturing a Window
Capture Screen
Activates the capture screen function.

Related Topic:
Capturing the Entire Screen
Hide RezSolution
Removes or hides the RezSolution window from the screen.

Related Topic:
Hiding and Unhiding RezSolution



Options Menu

Sizing Panel
Displays the sizing panel in the RezSolution window.

New Window on Clipboard Change
Creates a new document window each time the windows Clipboard is updated with a new image.

Related Topic:
Capturing Multiple Images
Replace On Open
Replaces the contents of the current document window when a file is opened.

View Picture
Allows you to view the contents of the current document    window on the full screen.

Swap Red And Blue On Open
Exchanges the red and blue color data when a file is opened.

Related Topic:
Converting 16-color Files from Windows 2.x to 3.0
Swap Red And Blue
Exchanges the red and blue data on the graphic image in the current document window.

Custom To Standard Palette On Open
Converts custom colored image files to the standard palette when a file is opened.



Window Menu

Cascade
Causes the currently open document windows to overlap so that each title bar is visible.

Tile
Rearranges the currently open document windows so that all are visible within the work space.

Arrange Icons
Lines up the document icons across the bottom of the work area.

Close All
Closes all of the currently open document windows.    Asks if you want to save a file if it contains unsaved 
changes.

Related Topic:
Closing Document Windows



Help Menu

Index
Displays an alphabetical list of all Help topics that are available.

Keyboard 
Displays the accelerators for performing some tasks with the keyboard instead of the mouse.

Commands 
Displays an explanation of commands.

Procedures 
Displays a description of how to use RezSolution

Using Help 
Displays a short tutorial and other information about using on-line Help.

About RezSolution... 
Displays RezSolution copyright and version information.



Converting from One File Format to Another

RezSolution lets you work with the following file formats.

.ATT .CUT .FIF .ICO .KFX .PCD .PSD .TIF .XPM

.BMP .DCX .GIF .IFF .LV .PCT .RAS .WMF .XWD

.CAL .DIB .GX2 .IMG .MAC .PCX .RLE .WPG

.CLP .EPS .ICA .JPG .MSP .PIC .TGA .XBM
If a file currently uses one of these formats, you can convert it to one of the other formats.

To convert a file from one format to another:

1. Open the existing graphic file.
If it is already open, make sure it is the active document window.

2. Choose Save As... from the File menu.
A Save As dialog box appears.

3. Select a file type from Save File As Type drop-down list.
The extension of the filename in the File Name text box automatically changes to reflect the selected 
file format.

4. Choose Ok.

The file is converted and saved under the new filename.    (The original file, which has a different filename
extension, still exists.)



Scaling Images Proportionately

There are two ways to scale images proportionately.    You can enter new values in the Width and Height 
apply data boxes or you can enter a new value in the Zoom % apply data box.

To enter new height and width values for a graphic:

1. Load the graphic files into RezSolution.
If it is already loaded, make it the active active document window.

2. Enter a new value in the Height apply data box.
3. Enter a new value in the Width apply data box.

Make this value proportionate to the Height value.    That is, if you tripled the height, triple the width.
4. Click on the Apply button.

The new height and width values are applied.

The file, however, is not permanently changed until you save it with the changes.    You can save the 
changes, experiment with additional changes, or undo the changes to return the graphic to its original 
state.    

To enter a Zoom % for a graphic:

1. Load the graphic into RezSolution.
If it is already loaded, make it the active document window.

2. Enter a new value in the Zoom % box.
Use a value greater than 100 to increase the image size proportionately.    Use a value that is less than
100 to decrease the image size.

3. Click on the Apply button.
The image size is increased or decreased as indicated.    The values in the Width and Height apply 
data boxes are automatically adjusted to reflect the new image size.    

As with any changes made with the Apply button, the file is not permanently changed until you save it with
the changes.



Stretching or Reducing Images

You can stretch or reduce an image by entering new values in the Width and Height apply data boxes.

When RezSolution expands or reduces an image it changes pixel values.    Pixels are proportionately 
added or subtracted to fit into the new image size.    Be aware that stretching or shrinking an image may 
effect the clarity of the picture.

To enter new height and width values for a graphic:

1. Load the graphic files into RezSolution.
If it is already loaded, make it the active active document window.

2. Enter a new value in the Height apply data box and/or the Width apply data box.
As an example, if you indicate a larger width value and do not change the height value, the image will 
be stretched horizontally.    

3. Click on the Apply button.
The new height and width values are applied.

The file, however, is not permanently changed until you save it with the changes.    You can save the 
changes, experiment with additional changes, or undo the changes to return the graphic to its original 
state.    

Note: When RezSolution expands or reduces an image it changes pixel values.    Pixels are 
proportionately added or subtracted to fit into the new image size.    Be aware that stretching or shrinking 
an image may effect the clarity of the picture.



Cropping Images

RezSolution allows you to crop an image.    In effect, you select the rectangular part of the image that you 
want to retain.    Any area not selected will not be part of the image.

1. Load the graphic file into RezSolution.
If it is already loaded, make it the active active document window.

2. Move the cursor into the active document window and position it at the top left corner of the area you 
want to select.    (The cursor appears as a crosshair with a box in the lower right quadrant.)

3. Press and hold the left mouse button and drag down and to the right.    (Hold down the Shift key to 
draw a square.)

4. Release the mouse button when the rectangle is the desired size.
5. Choose Copy from the Edit menu.

The selected image is copied to the Clipboard and can be seen in the Clipboard Viewer.

You can work with the cropped image in one of two basic ways:

· Manipulate the image in the Clipboard Viewer and optionally save it to a new file.
· Choose Paste from the Edit menu to paste the image from the Clipboard back into the document 

window from which it was copied.    (When you do this, the original image is completely replaced by the
pasted image.)



Converting 16-Color .PCX Files from Windows 2.x to 3.0

16-color .PCX files created in Microsoft Windows Version 2.x have the red and blue color data reversed.    
The colors in the image are wrong when displayed in Windows 3.0.    RezSolution solves this problem with
an option to swap (correct) the red and blue color data.    The graphic image then appears normal in 
Windows 3.0.

There are two Option menu commands that let you swap the red and blue color data: Swap Red and Blue
and Swap Red and Blue On Open.

To swap red and blue in one file:

1. Open the file you want to convert, or click on the appropriate document window to make it the active 
window.
Initially, the colors will not appear properly.

2. Choose Swap Red and Blue from the Options menu.    (This command is only available if the graphic 
file was created in Windows 2.x.)
The colors in the graphic are reversed and the image appears as intended.

If you plan to convert several 16-color files created in Windows 2.x, you can choose Swap Red and Blue 
On Open from the Options menu.    This toggles on the feature so that every time you open a file the swap
is performed automatically.    The feature does not affect files that are not 16-color graphics created in 
Windows 2.x.



Converting Black and White to Color

RezSolution lets you convert a black and white graphic file to color if you are working on a color system.    
For example, if you are working on a system that supports 16 colors, you can open a black and white 
graphic and convert it to 16 colors.

When you convert a file, it does not immediately appear colored.    In effect, it becomes a color graphic 
that uses only two colors, black and white.    Once the file has been converted and saved, you can then 
open the file in a paint program and use the color palette to add color to the graphic.

To convert an image from black and white to color:

1. Load the image into RezSolution.
If it is already loaded, make it the active document window.

2. Enter the appropriate value in the Colors apply data box.
For example, enter 16 if you are working on a 16 color system and want to convert the image to 16 
colors.

3. Click on the Apply button.
The image does not appear to have changed, however, the palette information in the header of the file 
has changed.    When you save and open the file in a graphic editor such as Paintbrush, a color palette
will be available and you can add color to the graphic.



Converting Color to Black and White

RezSolution allows you to convert your graphics to black and white without loosing image definition.    
Instead of taking colors and translating them into either black or white, it substitutes different hatch 
patterns for the different colors in the graphic file.    You can choose between levels of hatch patterns 
when converting to black and white.

For example, your 16 color image may be converted to solid white and solid black, or to 4 different hatch 
patterns that use varying amounts of white and black.    If you want to convert to solid, un-patterned black 
and white, you specify a value of 2/0.    If you want to use hatch patterns, specify a value of 2 followed by 
a / and the number of patterns from 1 to 5.    Acceptable values range from 2/0 to 2/5.

The following table indicates the effect produced by each hatch pattern conversion value:

Value Result

2 (Defaults to 2/4).    Uses black, white, and eight hatch patterns.

2/0 Uses black and white.    No patterns.

2/1 Uses black, white, and one hatch pattern.

2/2 Uses black, white, and three hatch patterns.

2/3 Uses black, white, and five hatch patterns.

2/4 Uses black, white, and eight hatch patterns.

2/5 Uses black, white, and thirteen hatch patterns.

To convert from color to black and white:

1. Load the image into RezSolution.
If it is already loaded, make it the active document window.

2. Enter the a value (from 2/0 to 2/5) in the Colors apply data boxes.
3. Click the Apply button.

The image is converted.

The image is not permanently changed until you save it with the changes.    You can save the changes, 
experiment with additional changes, or undo the changes to return the graphic to its original state.    



Converting from One Color Palette to Another

RezSolution lets you convert images from one palette to another.    The following color conversions are 
supported:

2 black and white (monochrome)

8 Windows 2.x basic color palette

16 Windows 3.0 standard (four plane graphic)

256 Standard and customized (eight plane graphic)

Note: RezSolution does not support 16 color custom palettes.

When you have a color graphic file that supports a different number of colors than your system, and you 
open that file in RezSolution it is automatically converted to the system number of colors.    For example, if
you are working on a 256 color system and open a 16 color graphic in RezSolution, the graphic is 
converted to 256 colors.    Note that this change is not permanent until you save the file.    Also, the file will
not automatically contain more colors simply because you convert it.    You must open a graphic editor, 
such as Paintbrush, and add color to it.

Caution: If you open and save a file that originally supported more colors than your system supports, that
graphic will be converted so that it uses the lesser number of colors.    For example, if you are working on 
a 16 color system and open and save a 256 color graphic, it will be converted to 16 colors.    To avoid 
converting an open file, simply close it without saving changes.



File Header
The color information about a specific file is stored in the file header.    When the graphic file is opened in 
a paint program, the color palette receives data from the file header.    For example, if the file uses up to 
16 colors and the system also supports 16 colors, the palette appears with 16 colors.    If the file uses 2 
colors, and the system supports 16 colors, the palette appears with only 2 colors (black and white).    The 
limit is the number of colors supported by your system.



Understanding the Active Window Data Bar

The active window data bar displays the sizing and color values for an image in the active window within 
RezSolution.    The active window is either the Clipboard Viewer or a document window.

Width and Height areas
These areas show the width and height of the graphic in the active window.

Colors area
If the graphic in the active window is monochrome, the Colors area shows the value 2.

If the graphic in the active window is color the Colors area shows the number of colors supported by the 
current system.

As an example, if you open a 256-color graphic on a 16-color system, the Colors value in the active 
window data bar is 16 because that is the number of colors supported by the system.    Similarly, when an 
8-color graphic is opened on a 16-color system, the Colors value is 16.    In both cases the graphic is 
converted to a 16 color graphic. 

Caution:    When you open a graphic on a system that supports fewer colors, the quality of the image may
be degraded.    For example, if you open a 256-color graphic on a 16-color system, the graphic will only 
be displayed using 16 colors.    DO NOT SAVE THE IMAGE and the file will remain in its original 256-color
state.    IF YOU SAVE THE IMAGE IT WILL BE PERMANENTLY CHANGED.

X Res and Y Res areas
If the graphic in the active window is a .PCX file, these areas show the resolution of the system on which 
the graphic was originally created.

If the graphic in the active window is a .BMP or .RLE file, these areas show the resolution of the current 
system.

Related Topic:
Understanding the Apply Data Boxes



Understanding the Apply Data Boxes

The apply data boxes are the white, lower row of boxes to the right of the Apply button.    When you first 
run RezSolution, these boxes contain the system defaults.    The Colors box contains the number of colors
supported by the current system, the X Res and Y Res boxes describe the resolution of the current 
system, and the Zoom % is set to 100%.    If there is an image on the Clipboard (in the Clipboard Viewer) 
the width and height of the image appear in the Width and Height boxes.

Use the apply data boxes to enter the values you want to apply to the image in the active window.    Once 
you enter one or more new values in the apply data boxes and click the Apply button, the values in the 
grey, active window data bar are recalculated to reflect the change(s).    

To undo the changes, click on the X button.    To return the active window data bar to the system defaults, 
click the Defaults button.

Related Topics:
Understanding the Active Window Data Bar
Applying Changes to an Image
Using the Apply Data Boxes



Applying Changes to an Image

Use RezSolution to apply changes to the size, color, and/or resolution of a graphic. 

Note: Applying a change is different from saving changes to a file.    Applied changes can be undone, 
saved changes are permanent.

There are two basic ways to apply changes to a graphic:

· In some situations, changes are applied to a file as soon as it is opened in RezSolution.
· In other situations, you must deliberately choose to apply changes to an image in either the Clipboard 

Viewer or the active window.

The color of an image is sometimes changed as soon as you open it in RezSolution.    For example, if you
open a 256-color image in RezSolution on a 16-color system, the graphic immediately appears in only 16-
colors.    The change is permanent only if you save the file.    If you close the file without saving it, the file 
still uses 256 colors.

You can also use the apply data boxes to change an image in either the active document window or the 
Clipboard Viewer.

Related Topics:
Using the Apply Data Boxes
Understanding the Active Window Data Bar



Using the Apply Data Boxes

You can also use the apply data boxes to change the following attributes of an image in either the active 
document window or the Clipboard Viewer:

Width and Height boxes
The width and height of an image are measured in pixels.    Changing the width and/or height of an image 
can reduce or stretch the image horizontally and/or vertically to a new size.    The width value can be 
changed by editing the value in the Width box, the height value can be changed by editing the value in the
Height box, or both values can be automatically altered by changing the value in the Zoom % box.

Related Topics:
Scaling Images Proportionately
Stretching or Reducing Images
Cropping Images
Colors
The value in the Colors box is the number of true (not mixed) colors available for each pixel.    
RezSolution can only change from the current number of system colors to 2 colors (black and white), or 
from 2 colors to the current number of system colors.

RezSolution supports image color conversion such as 256 to 16, 16 to 2, 8 to 16, etc.    For example, if 
you are displaying your image on a 16 color system and the image was created and saved with 8 colors, 
the system must convert the image each time it is displayed.

Related Topics:
Converting Black and White to Color
Converting Color to Black and White
Converting from One Color Palette to Another

X Res and Y Res
By default, X Res is the horizontal value of the current screen resolution and Y Res is the vertical value of
the current screen resolution.    When you change the values these boxes, the Width and Height values in 
the active window data bar are automatically recalculated.    RezSolution allows you to simulate any X 
and/or Y resolution.    (To return this value to the system default, click on the Defaults button.)

Related Topic:
Changing Resolution across Systems
Understanding Image Resolution

Zoom % 
Zoom % is the percentage by which you want to increase or reduce the size of the image.    When an 
image is opened the default zoom level is 100%.    

When you want to enlarge an image, use a zoom percentage that is greater than 100%.    For example, 
200% doubles the size of the image.    When you want to reduce the size of an image, use a zoom 
percentage that is less than 100%.    For example, 50% reduces the image to one half its size.

When a new zoom percentage is applied, the width and height of the image are changed proportionately.  
That is, if you specify a zoom percentage of 200%, both the width and height are doubled.

Related Topic:
Scaling Images Proportionately



Undoing Applied Changes

Use the X button to undo changes applied with the Apply button.    If the image being manipulated is in the
Clipboard Viewer, it is returned to its original state.    If the image is a file, it is returned to the condition that
was current as of its last file save.



Displaying the Current System Defaults

Press the Defaults button to return the system default values for Colors, X Res, Y Res, and Zoom %.

Related Topic:
Understanding the Apply Data Boxes



Using the Clipboard Viewer

The Clipboard Viewer is a permanent feature within the workspace.    It is a special window that lets you 
view and manipulate the contents of the Windows Clipboard.    Typically, you place graphic images on the 
Clipboard by capturing a screen, the contents of a window, or some other region of the screen.    You can 
also place items on the Clipboard through the Copy command from the Edit menu.

The Clipboard Viewer is updated each time a bitmap graphic image is sent to the Windows Clipboard.    
The Clipboard Viewer is always open, and cannot be closed.

Note: Only bitmap graphic images can be seen in the Clipboard Viewer.

You toggle on a feature so that every time you capture an image or copy an image to the Clipboard, 
RezSolution also places the image in a new document window.    To do this, choose New Window On 
Clipboard Change from the Options menu.

Related Topic:
Copying an Image to the Clipboard Viewer
Pasting an Image from the Clipboard



Using the Mouse Data

The Mouse Data area displays the current location of the mouse pointer and the size of a selected area.    
In order for the mouse to give current data it must be positioned over the Clipboard Viewer or a document
window.    When the mouse cursor is positioned over a graphic image, the pointer appears as a cross with
a box in the lower right quadrant.    When the mouse is in an invalid data position, it appears as an arrow.

The location of the mouse pointer is indicated by the XY coordinate values.    This value is always relative 
to the upper left corner (0,0) of the document window in which the mouse pointer is currently positioned.    
A document window does not have to be made active to give mouse coordinate data.    

The width and height of a selected area (in pixels) are indicated by the WH values.

Related Topics:
Cropping Images
Copying an Image to the Clipboard Viewer



Loading Images into RezSolution

The first step toward manipulating an image in RezSolution is to bring the image either into the Clipboard 
Viewer or into a document window.    

Three basic ways to load an image into the Clipboard Viewer are:

· Capturing any screen, window, or rectangular region that appears in Windows.    (This means using the
capture facilities that come with Windows and/or RezSolution.)

· Copying part of an image that appears in a RezSolution document window.    (This means using the 
Copy command in RezSolution's Edit menu.)

· Copying or cutting an area from an image in another application that uses the Windows Clipboard.    
(This means using the Edit menu commands of another application to place an item on the Clipboard.  
Refer to the documentation for the other application for information on copying or cutting items to the 
Clipboard.)

Two common ways to load an image into a document window are:

· Opening an existing file in RezSolution. 
· Opening a new document window and pasting an image into it.



Capturing New Images

You can use RezSolution to capture any screen, window, or region of the screen in Windows.    Once the 
image is captured, you can apply size or color changes to it and optionally save it to a file.

By default, when you capture an image it is placed on the Clipboard.    It can therefore be viewed and 
manipulated in the Clipboard Viewer.    Each time you capture an image, it replaces the last image on the 
Clipboard.    Optionally, you can choose New Window on Clipboard Change from the Options menu so 
that when an image is captured, it is placed on the Clipboard and placed in a new document window.    
This is helpful if you want to capture a number of images, load each into a document window, and 
manipulate them later.

Related Topics:
Capturing the Entire Screen
Capturing a Window
Capturing a Region
Capturing Multiple Images



Capturing a Region

To capture a region, you must have the RezSolution window opened.    Typically you run RezSolution, 
resize it, and move it out of the way so that it doesn't interfere with the region of the screen you want to 
capture.    

By default, when you capture an image it is placed on the Clipboard.    It can therefore be viewed and 
manipulated in the Clipboard Viewer.    Each time you capture an image, it replaces the last image on the 
Clipboard.    Optionally, you can choose New Window on Clipboard Change from the Options menu so 
that when an image is captured, it is placed on the Clipboard and placed in a new document window.

To capture a region:

1. Choose Capture Region from the Capture menu or press CTRL + R.
The cursor becomes a hand

2. Position the mouse pointer in the upper left corner of the region.
3. Press the mouse button and drag to the lower right corner of the region.

A box appears to indicate the selected area.    To draw a perfect square, hold down the SHIFT key while
you drag the mouse.    If you are not satisfied with the selected area, click the right mouse button to 
cancel the region capture.

4. Release the mouse button.
The area is copied to the Windows Clipboard and is displayed in the Clipboard Viewer window.

Once an image is in the Clipboard Viewer you can apply changes to it and optionally save the image to a 
file.

Related Topic:
Hiding and Unhiding RezSolution



Capturing a Window

RezSolution does not have to be running to capture an application window.    An application window is 
captured using a feature of Windows.    

By default, when you capture an image it is placed on the Clipboard.    It can therefore be viewed and 
manipulated in the Clipboard Viewer.    Each time you capture an image, it replaces the last image on the 
Clipboard.    Optionally if RezSolution is running when you capture a window, you can choose New 
Window on Clipboard Change from the Options menu so that when an image is captured, it is placed on 
the Clipboard and placed in a new document window.

To capture a window:

1. Position the mouse pointer in the window to be captured.
2. Click the left mouse button to select the window.
3.. Press the ALT + PRINT SCREEN keys.    

The active window is copied to the Windows Clipboard and is displayed in the Clipboard Viewer.
Note: When capturing application windows that use 256 colors, it is recommended that you run 
RezSolution, because RezSolution captures the color palette along with the image.

Once an image is in the Clipboard Viewer you can apply changes to it and optionally save the image to a 
file.



Capturing the Entire Screen

RezSolution does not have to be running to capture an entire screen.    An entire screen is captured using 
a feature of Windows.

By default, when you capture an image it is placed on the Clipboard.    It can therefore be viewed and 
manipulated in the Clipboard Viewer.    Each time you capture an image, it replaces the last image on the 
Clipboard.    Optionally, if RezSolution is running when you capture a screen, you can choose New 
Window on Clipboard Change from the Options menu so that when an image is captured, it is placed on 
the Clipboard and placed in a new document window.

To capture a screen:

· Press PRINT SCREEN on the keyboard.    
The screen is copied to the Windows Clipboard and is displayed in the Clipboard Viewer.

Note: When capturing screens that are using 256 colors, it is recommended that you run RezSolution, 
because RezSolution captures the color palette along with the image.

Once an image is in the Clipboard Viewer you can apply changes to it and optionally save the image to a 
file.

Related Topic:
Hiding and Unhiding RezSolution



Capturing Multiple Images

Multiple images can be captured and placed into windows without returning to RezSolution between each 
screen capture.    This procedure can be used for capturing graphic images from a Windows application 
for developing software application tutorials or presentations.

To capture multiple images:

1. Choose New Window on Clipboard Change from the Options menu.
2. Capture the images by following one of the techniques for capturing a region, a window, or an entire 

screen.
Each time you capture an image, it is pasted onto the Clipboard.    Every time the Clipboard is 
modified, a new document window is created and the contents of the Clipboard Viewer are copied into 
the new window.

Once an image is loaded in a document window you can manipulate it, and optionally save it to a file.



Hiding and Unhiding RezSolution

You may want to hide the RezSolution window when you capture a full screen.    If you make RezSolution 
an icon, it remains on the screen.    You may not want to see the icon on the captured image.

To hide RezSolution's window:

· Choose Hide RezSolution from the Capture menu or press CTRL + D.    
RezSolution immediately displays a message reminding you of how to unhide RezSolution.    
The RezSolution window remains the active window until another window is selected.    Press CTRL + 
R to activate the Capture Region Command, and select a region of the current screen, or use the 
PRINT SCREEN keys to capture the entire screen.    

Note: The Capture Region Command is only active when RezSolution is the current selected window.    If 
you hide RezSolution and click on another window to make it active, the CTRL + R (capture region) option 
is no longer available.    

To unhide RezSolution's window:
1. Press CTRL + ESC or double click on the Windows Desktop.

The Task List dialog box is displayed.
2. Choose RezSolution
3. Select Switch To.

The RezSolution window is restored



Copying an Image to the Clipboard Viewer

You can copy images onto the Clipboard by using RezSolution's Copy command or by using the Edit 
menu commands of another application that is designed to place items on the Windows Clipboard.    
(Refer to documentation for the other application for information on copying or cutting items to the 
Clipboard.)

To copy an entire image to the Clipboard from a RezSolution document window:

1. Click on the document window that contains the image you want to copy.
This makes it the active window.

2. Choose Select All from the Edit menu.
The entire graphic image is selected.

3. Choose Copy from the Edit menu.
The image is copied to the Clipboard.

Once the image is on the Clipboard, you can apply changes to it, and optionally, save it to a new file.    
The image in the original document window remains unchanged.    

To copy a portion of an image from a RezSolution document window to the Clipboard:

1. Click on a document window to make it the active window.
2. Position the mouse pointer in the upper left corner of the area to be copied.

The mouse pointer becomes a cross when positioned on a selectable area.
3. Press the left mouse button and drag down and to the right.    

A box appears to indicate the selected area.    To draw a perfect square, hold down the SHIFT key while
you drag the mouse.    If you are not satisfied with the selected area, click the right mouse button to 
cancel the select region option.

4. Release the mouse button when the area is selected.    

Once the image is on the Clipboard, you can apply changes to it, and optionally, save it to a new file.    
The image in the original document window remains unchanged.

Related Topic:
Capturing New Images



Pasting an Image from the Clipboard

You can take an image from the Clipboard and paste it into a document window.

For example, when you capture an image from outside RezSolution it is automatically placed on the 
Clipboard.    The captured image on the Clipboard appears in the Clipboard Viewer.    You can apply 
changes to the image while it is in the Clipboard Viewer.    However, you might want to paste the image 
into a document window so that it is not accidentally replaced if you capture or copy a new image to the 
Clipboard.

The document window where you paste an image can be a new, empty one that you open just for this 
purpose, or it can be an open document window that already contains an image.

Warning: If you paste an item from the Clipboard into a document window that already contains an 
image, the image is completely replaced by the pasted item.

To paste an image from the Clipboard:

1. Open a new document window or click in an open document window to make it the active window.
2. Choose Paste from the Edit menu.

The image on the Clipboard (in the Clipboard Viewer) is pasted into the active window.    Any image 
previously in that window is replaced by the pasted item.

Related Topics:
Copying an Image to the Clipboard Viewer
Capturing New Images



Understanding Image Resolution

Resolution is the number of horizontal and vertical pixels, and the number of color values available for 
each pixel.    The resolution of a graphic is commonly stated as the number of pixels across by the 
number of pixels down, and the number of available colors.    For example, "640 pixels by 480 pixels, 256 
colors", written 640 x 480 x 256.

Different computer systems are designed to display graphics of different resolution.    For example, one 
system may be capable of displaying graphics that are 640 x 480, 16 colors, while another system may 
be capable of displaying graphics that are 1024 x 768, 256 colors.    In general, the more pixels on the 
screen, the more well-defined and detailed an image can appear.

The resolution of a computer system is determined by its graphics adapter and monitor.    Microsoft 
Windows supports several graphics adapters with varying resolutions.

Enhanced Graphics Adapter (EGA) 640 x 350 (16 color)

Video Graphics Array (VGA) 640 x 480 (16 colors)

Enhanced Video Graphics Array (EVGA) 800 x 600 (256 colors)

Super Video Graphics Array (SVGA) 1024 x 768 (256 colors)

Note: A low resolution driver is available for Windows 3.0 users.    Contact your IconAuthor sales 
representative for more information.

When graphic images are saved to a bitmap file, the resolution of the graphic is saved in the file header 
data.    When the graphic is displayed in an alternate screen resolution, the image appears distorted.

Related Topic:
Changing Resolution across Systems



Changing Resolution across Systems

You may need to change the resolution of graphics because you are moving them from one system to 
another.    For example, if you take a graphic file that was created as a full screen image on a VGA 640 x 
480 system and open it on an SVGA 1024 x 768 system, the image will no longer be full screen.

Changing File Resolution:

1. Before you open the graphic being converted, you must note the original resolution of the graphic.
2. The X Res and Y Res values in the white apply data boxes initially describe the resolution of the 

current system.    Replace these values with the resolution of the system originally used to create the 
graphic.

3. Open the graphic you want to convert.
4. Click on the Defaults button.
5. Click on the Apply button.

The image size is automatically adjusted.



Saving New Images

Warning: Once you save a file, you cannot undo changes that you have applied.

You can save an image on the Clipboard to a new file or you can save an image in an untitled document 
window to a new file.

To save clipboard and new document window images:

1. Click anywhere within the Clipboard Viewer window or the new document window to make it the active 
window.

2. Select Save As from the File menu to save the image to a new file.
The Save As dialog box is displayed.

3. Enter a filename in the File Name text box.
If necessary, use the Directories list box to change the path used to save your file.

4. Select a file format from the Save File As Type drop-down list.
The file extension is automatically entered into the File Name text box.    

5. Complete the File Name.

6. Click on OK to save the image.



Saving Changes to Existing Files

Warning: Once you save a file, you cannot undo changes that you have applied.

Whenever you change an existing file, you must decide whether to save the image to the same file (Save 
command), or save the image to a new file (Save As command).    When an existing image is saved to a 
new file, the contents of the original file remain the same as before any changes were made.

To save changed files to the same filename:

1. Click anywhere within the document window containing the image you wish to save.    The window 
becomes the active window.

2. Choose Save from the File menu.
The image is updated and saved to the existing filename specified in the document window title bar.    
The Save Command replaces the changed file with the original file.

Hint: To preserve the original file, make a working copy and edit the working copy.    This procedure 
insures that you can always return back to the original file if the changed results are not what you 
expected.

To save and rename changed files:

1. Click anywhere within the document window containing the image you wish to save.    The window 
becomes the active window.

2. Select the Save As Command from the File menu.
The Save As dialog box appears to prompt you for the filename of the graphic.    Since the graphic has 
previously been saved, the current filename appears as the default filename.    You can accept this 
filename (same as Save) or enter a new filename.    

3. Edit or re-enter a new filename in the File Name text box.
A filename can be modified by either making a change to the existing filename using the keyboard, or 
by choosing a new file format from the Save File As Type drop-down list.    When a new file format is 
selected, the extension of the file in the File Name text box is automatically updated.

4. Click on OK to save the image to the new file.
The title bar of the document window is changed to reflect the new filename.    The Save As...    
Command saves the file to the current directory.

Note: This method of saving a file preserves the original file.    



Automatically Saving Changes to Multiple Files

Use the Open,Apply,Save Command from the File menu to automatically open one or more files in one 
directory, apply the same changes to each file, and save each file.    The first file is opened, changed, and 
saved, then the second, etc.    This feature is useful, for example, if you want to convert 30 files to black 
and white, or increase the size of 3 files by 150%.    

To open, apply and save a file:

1. Use the keyboard to enter new values in one or more of the apply data boxes.
For example, to increase the size of a group of files by 125%, enter 125 in the Zoom % box.

2. Select the Open,Apply,Save Command from the File menu.
3. Use the Directories list box to move to the directory that contains the file(s) you want to change.
4. Use the Files list box to select the file or files to be changed, or click on the Select All button to select 

all the files in the current directory.
5. Optionally, select the Confirm Save check box if you want to confirm the changes to each file before it 

is saved.
6. Optionally, choose Options >> if you want to specify a different file format.
7. Optionally, choose Info... if you want to view an Information dialog box that shows the current attributes

of a selected graphic file.
If several files are selected when you choose Info... an Information dialog box appears for the first file.  
When you choose OK to close that dialog box the information for the second file appears, and so on.

8. Choose OK to accept the contents of the Open,Apply,Save dialog box, or choose the Cancel button to 
cancel the Open,Apply,Save Command and return to RezSolution.

When you choose OK, the new attributes are applied to each file and each file is saved with its original 
filename (unless a new file format was selected).    To cancel the Open,Apply,Save Command press the 
ESC Key.



Working with Document Windows

A document window is another kind of window that you can open within the workspace.    A document 
window is a window within the RezSolution workspace where you can display an image.    For example, 
when you open a graphic file in RezSolution, the image is displayed in a document window.    You can 
have as many document windows open as your system's memory will hold.    The document window title 
bar contains the path and name of the file.    If the image in a document window has not yet been named, 
the title bar is labeled "(Untitled)".

To show only the filename in the title bar of a document window, choose Show File Path from the Window 
menu. (This deselects the full pathname feature which is on by default.)

You can move, resize, minimize, and restore document windows.    You can also close them.    In order to 
apply changes to an image in a document window, that document window must be the active window.    
Click anywhere in a window to make it active.

In many ways, the Clipboard Viewer behaves similarly to a document window.    For example, you can 
apply changes to an image in the Clipboard Viewer and save the image to a file.    The basic difference 
between the Clipboard Viewer a document window is that the contents of the Clipboard Viewer is 
replaced when an image is cut, copied, or captured.    Also, unlike document windows, the Clipboard 
viewer cannot be closed.

Related Topic:
Using the Clipboard Viewer



Opening New Document Windows

When you open a new document window it is empty and untitled.    You can load an image into the 
window by pasting the Clipboard contents into it.

To open a new document window:

· Choose New from the File menu.
A new document window is created.    The contents of the window is blank and the title bar contains the
text "(Untitled)".    

Related Topic:
Pasting an Image from the Clipboard



Opening Existing Graphic Files

When you open an existing graphic file in RezSolution it is automatically loaded into a document window.  
One or more files can be opened at a time.    The RezSolution workspace can contain any number of 
opened windows.

To open an existing graphic file:

1. Select Open...    from the File menu
2. Move to the directory containing the graphic file(s) you want to open.
3. Select the file(s) you want to open.

To select all the files, click on the Select All button.
To select two or more files in sequence, click on the first filename, press and hold the SHIFT key, click 
on the last filename in the sequence, and release the SHIFT key.
To select two or more files out of sequence, click on the first filename, press and hold the CTRL key, 
click on each additional filename you want to select, and release the CTRL key.



Closing Document Windows

You can close one or all document windows in the workspace.    If an image in a document window 
contains unsaved changes, RezSolution will ask if you want to save the changes before closing.

To save and close a document window:

· Double click on the Control-menu box of the window you want to close.
If there are any changes to the selected window that have not been saved, you are prompted to save 
the changes.

To close all the document windows:

· Select Close All from the Window menu.
If there are any changes to the window(s) that have not been saved, you are prompted to save the 
changes.
If you respond Yes to the save changes dialog box you are prompted with the Save As dialog box.

Warning: When you save changes made to a graphic file, the file is permanently altered.



Deleting Graphic Files

RezSolution lets you delete graphic files.    Use this feature with caution because the deleted file is not just
removed from RezSolution, it is deleted from your disk. 

To delete a graphic file:
1. Make sure the file you want to delete is open and in the active document window.
2. Choose Delete from the File menu.    

A Dialog box appears with the directory path of the selected file, asking you to confirm that you want to
delete the file. 

3. Select Yes if you want to delete the selected file or No to return to the RezSolution window.



Printing Graphic Files

RezSolution lets you print a graphic file if your printer is properly installed and selected.    The appearance
of the printed page varies depending on the current page setup.    You can use the default settings for 
page setup, or you can use the Page Setup... command from the File menu to change the layout of the 
printed page.    

To print a graphic file:

1. Make sure the file you want to print is open and in the active document window.
2. Choose Print from the File menu.

A dialog box appears informing you that the print process has begun.    Optionally, choose Cancel to 
cancel the Print Command.



Changing the Page Setup

When you print a file, you can use the default margin and header/footer settings or you can use the Page 
Setup dialog box to customize the layout of the page.

To open the Page Setup dialog box:
· Choose Page Setup... from the File menu.

To reset margins:
1. Click in the appropriate box in the Margins area and enter a new value.
2. Choose OK.

To setup headers and footers:
· Use the Header and Footer text boxes to enter text and/or any codes you want to appear at the top 

and bottom of each page.
For example, you can type the word "Date" followed by a space and &d in the Header text box.    This 
generates text such as "Date 12/15/91" at the top of the printed page. 

Use the following codes to generate and format information in the Header and Footer text boxes:

&d Generates the current date.

&p Generates page numbers.

&f Generates the current filename.

&l Justifies the text that follows at the left margin.

&r Justifies the text that follows at the right margin.

&c Centers the text that follows.

&t Generates the current time.



Quitting RezSolution

To exit from RezSolution, choose Exit from the File menu.    

If there are any unsaved changes to files in document window(s), you are prompted to save the changes.

The dialog box gives you the option to save the changes, not save the changes, or cancel back to your 
last working position within RezSolution.

If you respond Yes to the save changes dialog box a Save As dialog box appears.

To exit without saving the changes, select No.



RezSolution Contents

The Contents lists the Help topics available for RezSolution.    Use the scroll bar to see entries not 
currently visible.

Keyboard
RezSolution Keys

Commands
Capture Menu
Edit Menu
File Menu
Help Menu
Options Menu
Window Menu

Procedures

Applying Changes to an Image
Automatically Saving Changes to Multiple Files
Capturing a Region
Capturing a Window
Capturing Multiple Images
Capturing New Images
Capturing the Entire Screen
Changing Resolution across Systems
Changing the Page Setup
Closing Document Windows
Converting Black and White to Color
Converting Color to Black and White
Converting from One Color Palette to Another
Converting from One File Format to Another
Converting 16-Color Files from Windows 2.x to 3.0
Copying an Image to the Clipboard Viewer
Cropping Images
Deleting Graphic Files
Displaying the Current System Defaults
Hiding and Unhiding RezSolution
Loading Images into RezSolution
Opening Existing Graphic Files
Opening New Document Windows
Pasting an Image from the Clipboard
Printing Graphic Files
Quitting RezSolution
Saving Changes to Existing Files
Saving New Images
Scaling Images Proportionately
Stretching or Reducing Images
Understanding Image Resolution
Understanding the Active Window Data Bar
Understanding the Apply Data Boxes
Undoing Applied Changes
Using the Apply Data Boxes
Using the Clipboard Viewer
Using the Mouse Data
Working with Document Windows





RezSolution Keys

The following accelerator keys and key combinations are available in RezSolution:

Menu Command Key(s)

Edit Undo Alt + Backspace

Copy Ctrl + Insert

Paste Shift + Insert

Capture Capture Region Ctrl + R

Capture Window Alt + PrintScreen

Capture Screen PrintScreen

Hide RezSolution Ctrl + D

Options View Picture Ctrl + C

Window Cascade Shift + F5

Tile Shift + F4

Additionally, you can use the following keys to perform the corresponding functions:

Key Function

Escape Press the Escape key to cancel a File Open process.

Shift Press and hold the Shift key while using the mouse to 
select a perfectly square (versus rectangular) portion of a 
graphic.

Page Up Scrolls up in the active document window.

Page 
Down 

Scrolls down in the active document window.



RezSolution Commands

To get help with a command, choose the appropriate menu.

File Menu

New... 
Open... 
Save 
Save As... 
Open, Apply, Save...
Delete
Page Setup...
Print
Printer Setup...
Exit

Edit Menu

Undo
Copy 
Paste 
Clear 
Select All
Copy To... 

Capture Menu

Capture Region
Capture Window
Capture Screen
Hide RezSolution

Options Menu

Sizing Panel
New Window on Clipboard Change
Replace On Open
View Picture
Swap Red And Blue On Open
Swap Red And Blue
Custom To Standard Palette On Open

Window Menu

Cascade
Tile
Arrange Icons
Close All

Help Menu

Index
Keyboard 
Commands 
Procedures 
Using Help 
About RezSolution... 





RezSolution Procedures

Changing Size
Understanding the Active Window Data Bar
Understanding the Apply Data Boxes
Using the Apply Data Boxes
Applying Change to an Image
Undoing Applied Changes
Cropping Images
Scaling Images Proportionately
Stretching or Reducing Images

Changing Colors
Understanding the Active Window Data Bar
Understanding the Apply Data Boxes
Using the Apply Data Boxes
Applying Change to an Image
Undoing Applied Changes
Converting Black and White to Color
Converting Color to Black and White
Converting from One Color Palette to Another
Converting 16-Color Files from Windows 2.x to 3.0
Displaying the Current System Defaults

Changing Resolution
Understanding Image Resolution
Understanding the Active Window Data Bar
Understanding the Apply Data Boxes
Using the Apply Data Boxes
Applying Changes to an Image
Undoing Applied Changes
Changing Resolution across Systems
Displaying the Current System Defaults

Working with the Clipboard Viewer
Using the Clipboard Viewer
Loading Images into RezSolution
Copying an Image to the Clipboard Viewer
Pasting an Image from the Clipboard
Using the Mouse Data
Cropping Images

Capturing Images
Capturing New Images
Capturing a Region
Capturing a Window
Capturing the Entire Screen
Capturing Multiple Images
Hiding and Unhiding RezSolution

Managing Files and Document Windows
Working with Document Windows
Loading Images into RezSolution
Opening New Document Windows



Opening Existing Graphic Files
Deleting Graphic Files
Saving New Images
Saving Changes to Existing Files
Converting from One File Format to Another
Automatically Saving Changes to Multiple Files
Closing Document Windows
Quitting RezSolution

Printing Files
Changing the Page Setup
Printing Graphic Files




